728x90
문제
(A+B)%C는 ((A%C) + (B%C))%C 와 같을까?
(A×B)%C는 ((A%C) × (B%C))%C 와 같을까?
세 수 A, B, C가 주어졌을 때, 위의 네 가지 값을 구하는 프로그램을 작성하시오.
입력
첫째 줄에 A, B, C가 순서대로 주어진다. (2 ≤ A, B, C ≤ 10000)
출력
첫째 줄에 (A+B)%C, 둘째 줄에 ((A%C) + (B%C))%C, 셋째 줄에 (A×B)%C, 넷째 줄에 ((A%C) × (B%C))%C를 출력한다.
예제 입력 1
5 8 4
예제 출력 1
1
1
0
0
내 코드
const readline = require("readline");
const rl = readline.createInterface({
input : process.stdin,
output : process.stdout
});
let input = [];
rl.on("line", function(line){
input = line.split(' ').map((el) => parseInt(el));
}).on("close", function(){
let a = (input[0] + input[1]) % input[2];
let b = (input[0] % input[2] + input[1] % input[2]) % input[2];
let c = (input[0] * input[1]) % input[2];
let d = ((input[0] % input[2]) * (input[1] % input[2])) % input[2] ;
console.log(`${a}\n${b}\n${c}\n${d}`);
});
결과
> 5 8 4 1 1 0 0 |
728x90
'프로그래밍 > 백준 알고리즘' 카테고리의 다른 글
[백준 / node.js] 1330번: 두 수 비교하기 (0) | 2021.07.20 |
---|---|
[백준 / node.js] 2588번: 곱셈 (0) | 2021.07.20 |
[백준 / node.js] 10869번: 사칙연산 (0) | 2021.07.20 |
[백준 / node.js] 1008번: A/B (0) | 2021.07.20 |
[백준 / node.js] 10998번: A x B (0) | 2021.07.20 |
댓글